Having read through quite a few posts, I'm hesitant to add another one



to the pile but here it is.  I've exhausted almost all the suggestions



I have seen previously.  One thing that never seems to get answered



though is how to get port 3389 to listen appropriately.  It is showing



has the selected port in the registry.  Here it is:



Windows 2000 server, Terminal Services configured and running however



port 3389 is not established or listening.



Troubleshooting steps already taken:



1.) Terminal Service is up and running in services.mgr



2.) I have run netstat -a -n.  Port 3389 is definitely NOT listening or



established.  As a double check, I have also tried to telnet to the



machine and it fails on a connection error.



3.)  There is no firewall on the machine or on my internal network.  In



fact, this machine has worked in the past and I have a Windows 2003 SBS



server that works.



4.)  The machine was running in Application Server Mode, but I have



since switched it to Remote Administration mode just to check if it



could be an issue with my License server.  This had no effect.



5.)  I removed Symanted Antivirus Corporate Edition, just in case it



was blocking port 3389.



6.) I have insured that no filters are running on my network connection



that might prohibit entry through this port.



7.) I have tried changing the port that Terminal Services use.



8.) I have tried reinstalling (through upgrade) the operating system.



I tried reinstalling SP 4.



9.) I have verified that port number 3389 is located in the registry.



10.) Please DO NOT suggest checking the Remote tab in System



properties. This is a 2000 server and the tab does not exist.  In this



same vein, unless someone can assure me differently, I do not believe



there is a local security policy that "Enables remote desktop



connection" in Server 2000.  I've checked already.  If there should be



one, I don't have it on my system.



This issue all started after I reinstalled the operating system as a



result of Active Directory Issues I was having with replication.  The



reinstall did fix these problems, but since, my terminal services are



not running properly.



Thanks.



Mike




Windows Server - Terminal Services not working - Port 3389 not listening

Found the solution to my particular problem.   Article:



http://support.microsoft.com/kb/270588/en-us



CAUSE



This problem can occur if the server has been booted by using the Last



Known Good Configuration option more than once. When the server has



been booted into the last known good configuration more than once, the



ControlSet001 registry key is deleted. However, the following registry



value is hard-coded to use the ControlSet001 registry key:



Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal



Server\VIDEO\rdpdd\



Value name: \Device\Video0



Value type: REG_SZ



Value data:



\REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0



Back to the top



RESOLUTION



WARNING: If you use Registry Editor incorrectly, you may cause serious



problems that may require you to reinstall your operating system.



Microsoft cannot guarantee that you can solve problems that result from



using Registry Editor incorrectly. Use Registry Editor at your own



risk.



To resolve this problem, obtain the latest service pack for Windows



2000. For additional information, click the following article number to



view the article in the Microsoft Knowledge Base:



260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain



the Latest Windows 2000 Service Pack



To resolve this problem: 1. Start Registry Editor (Regedt32.exe).



2=2E Locate and click the following registry key:



HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal



Server\VIDEO\rdpdd\



Note If you do not have this key, use Registry Editor to create it.



3=2E Do one of the following:=B7 If you did not have to create the key in



step 2, change the following value



Name: \Device\Video0



Type: REG_SZ



Value: \REGISTRY\Machine\System\ControlSet001\Services\RDPDD\Device0



to the following:



Name: \Device\Video0



Type: REG_SZ



Value:



\REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0



=B7 If you had to create the registry key in step 2, add the following



value:



Subkey name: RDPDD



Name: \Device\Video0



Type: REG_SZ



Value:



\REGISTRY\Machine\System\CurrentControlSet\Services\RDPDD\Device0



4=2E After you change (or create) the value, restart the computer that is



running Terminal Services.