Windows Server - Unable to remove Exchange 2003 after 2007 Install

Asked By Matt Soukup on 12-Mar-08 09:55 AM
I am trying to uninstall Exchange 2003 after installing an Exchange 2007
server. I have followed the steps in the "How to Remove the Last Legacy
Exchange Server from an Organization"
(http://technet.microsoft.com/en-us/library/bb288905(EXCHG.80,printer).aspx).

When I try to uninstall Exchange 2003 I get the following error.

server."

There are still SMTP, System Attendant, and SystemMailbox mailboxes.

Here is the last part of the Exchange Setup logfiles on the C: drive of the
effected server.

[13:53:47] Entering CCompDomainPrep::ScGetEffectiveMode
[13:53:47] Leaving CCompDomainPrep::ScGetEffectiveMode
[13:53:47] Entering
ScDetermineIfLocalDomainServerGroupHasAlreadyBeenACLedOnExchangeCT
[13:53:47] Using cached result for domain "/dc=local/dc=columbus"
[13:53:47] The required permissions have already been set
[13:53:47] Leaving
ScDetermineIfLocalDomainServerGroupHasAlreadyBeenACLedOnExchangeCT
[13:53:47] Attempting to create the SRS DOB [checking whether SRS is
installed].
[13:53:47] Entering ScPRQ_DoesNotContainLastMAPIMDBInMixedModeAG
[13:53:47] This prerequisite has PASSED -- ID:62235 --
[13:53:47] Leaving ScPRQ_DoesNotContainLastMAPIMDBInMixedModeAG
[13:53:47]  ScPRQ_ServerIsNotRUSResponsibleServerInTheNonEmptyOrg
(f:\titanium\admin\src\udog\excommon\prereq.cxx:3133)
Error code 0X80072030 (8240): There is no such object on the
server.
[13:53:47]  CCompServer::ScCheckEVSPrerequisites
(f:\titanium\admin\src\udog\exsetdata\components\server\compserver.cxx:1358)
Error code 0X80072030 (8240): There is no such object on the
server.
[13:53:47]  CCompServer::ScCheckPrerequisites
(f:\titanium\admin\src\udog\exsetdata\components\server\compserver.cxx:955)
Error code 0X80072030 (8240): There is no such object on the
server.
[13:53:47]  CComExchSetupComponent::ScCheckPrerequisites
(f:\titanium\admin\src\udog\bo\comboifaces.cxx:1598)
Error code 0X80072030 (8240): There is no such object on the
server.
[13:53:47]  CComExchSetupComponent::ScCheckPrerequisites
(f:\titanium\admin\src\udog\bo\comboifaces.cxx:1598)
Error code 0X80072030 (8240): There is no such object on the
server.
[13:53:47] === IGNORING PREVIOUS ERRORS === HrSetProblemOnInstallAction,
while calling ScCheckPrerequisites
(f:\titanium\admin\src\udog\bo\comboifaces.cxx:1399)
The operation has completed successfully.
[13:53:47] Setup encountered an error while checking prerequisites for the
component "Microsoft Exchange":0X80072030 (8240): There is no such object on
the server.
[13:53:55]  CComBOIFacesFactory::QueryInterface
(f:\titanium\admin\src\udog\bo\bofactory.cxx:54)
Error code 0X80004002 (16386): No interface.

Thanks for any help.




Ed Crowley [MVP] replied on 12-Mar-08 09:35 PM
Search the KB for "Manually Remove Exchange".  There are processes for
removing Exchange from a server, removing a server from an organization, and
removing the entire organization manually.
--
Ed Crowley
MVP - Exchange